Composer Error: PHP requirement incompatible with your PHP Version

screen shot 2020 07 22 at 9 54 28 am

Add --ignore-platform-reqs flag to composer require command to get around this.

composer require drupal/date_recur:^2.0 --ignore-platform-reqs

Solution source